QuickFIX/J
  1. QuickFIX/J
  2. QFJ-644

keep getting quickfix.FieldNotFound: 268, eventhough it's set in the message

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Not a bug
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Environment:
      quickfix.fix50

      Description

      I keep getting quickfix.FieldNotFound: 268, index=1.
      As you can see from the message bellow 268 is set. Bellow is the sample code that is used to read the message. Please, advise

      Message:

      8=FIXT.1.19=36935=W49=ICAPServer56=FXDD34=452=20111021-15:09:16.535262=131920975731621021=255=EUR/USD461=RCSXX=0268=8269=0270=1.38898271=2000000269=0270=1.38897271=8000000269=0270=1.38854271=2000000269=1270=1.38855271=6000000269=1270=1.38856271=7000000269=1270=1.38857271=3000000269=1270=1.38858271=9000000269=1270=1.38859271=10000000010=128


      Sample Code:

       MarketDataSnapshotFullRefresh message= (MarketDataSnapshotFullRefresh) message;
       MarketDataSnapshotFullRefresh.NoMDEntries group= new MarketDataSnapshotFullRefresh.NoMDEntries();
       message.getGroup(1, group); // Throws the error above, quickfix.FieldNotFound: 268, index=1.


      1. QFJ644.java
        2 kB
        Laurent Danesi

        Activity

        Laurent Danesi added a comment -

        Hi,

        I tried to reproduce your problem but I was able to.
        Can you provide me a TestCase showing the problem or modify the attached test, please?

        Regards,

        Laurent

        Christoph John added a comment -

        Robert,

        you need to use a valid data dictionary if you want to correctly parse messages with repeating groups. The attached test case by Laurent also works for me. But if I do not pass the data dictionary into the Message(String, DataDictionary, boolean) I keep getting the same error as you: "quickfix.FieldNotFound: 268, index=1".

        Regards,
        Chris.


          People

          • Assignee:
            Christoph John
            Reporter:
            Robert Shalonov
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development