QuickFIX/J
  1. QuickFIX/J
  2. QFJ-204

Support interpolation during parsing of session settings

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Default Default
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.3.0
    • Component/s: Engine
    • Labels:
      None
    • Environment:
      All.

      Description

      Interpolation in 1.1.0 does not work with SenderCompID in default section, though it works elsewhere. Also possibly does not work with the other two fields used to generate session id.

      Often interpolation is required for SenderCompID since this should be different in dev, UAT and Production.

      Related to http://www.quickfixj.org/jira/browse/QFJ-114

      Thanks.

        Activity

        Steve Bate added a comment -

        The problem is actually not directly related to the default section. The settings are parsed and the interpolation previously only occurred when a variable was accessed. This means the session ID fields would not be interpolated before the internal session ID keys were created. This would have occurred whether or not the interpolated ID field was in the default section. I've modified the parser to interpolate variables during parsing. I've also added a new unit test to test the behavior.


          People

          • Assignee:
            Steve Bate
            Reporter:
            Parag Mehta
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development